summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDevaev Maxim <[email protected]>2018-09-26 02:57:24 +0300
committerDevaev Maxim <[email protected]>2018-09-26 02:57:24 +0300
commit81a5311349564a1016c4af2bf18ae872b650e85b (patch)
treed01fd027948494e22ae2c14334b98c1515e5e8a4 /setup.py
parentf3946f102fc167efdc53c73412b2c0d6ac6c72c5 (diff)
moved kvmd to the root
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py58
1 files changed, 58 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..35f3966d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,58 @@
+#!/usr/bin/env python3
+
+
+from setuptools import setup
+
+
+# =====
+def main() -> None:
+ with open("requirements.txt") as requirements_file:
+ install_requires = list(filter(None, requirements_file.read().splitlines()))
+
+ setup(
+ name="kvmd",
+ version="0.66",
+ url="https://github.com/pi-kvm/pi-kvm",
+ license="GPLv3",
+ author="Maxim Devaev",
+ author_email="[email protected]",
+ description="The main Pi-KVM daemon",
+ platforms="any",
+
+ packages=[
+ "kvmd",
+ "kvmd.extras",
+ "kvmd.extras.cleanup",
+ "kvmd.extras.wscli",
+ ],
+
+ package_data={
+ "kvmd": ["data/*.yaml"],
+ },
+
+ entry_points={
+ "console_scripts": [
+ "kvmd = kvmd:main",
+ "kvmd-cleanup = kvmd.extras.cleanup:main",
+ "kvmd-wscli = kvmd.extras.wscli:main",
+ ],
+ },
+
+ install_requires=install_requires,
+
+ classifiers=[
+ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
+ "Development Status :: 3 - Alpha",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Topic :: System :: Systems Administration",
+ "Operating System :: POSIX :: Linux",
+ "Intended Audience :: System Administrators",
+ "Intended Audience :: End Users/Desktop",
+ "Intended Audience :: Telecommunications Industry",
+ ],
+ )
+
+
+if __name__ == "__main__":
+ main()