summaryrefslogtreecommitdiff
path: root/kvmd/setup.py
diff options
context:
space:
mode:
authorDevaev Maxim <[email protected]>2018-06-29 00:29:24 +0300
committerDevaev Maxim <[email protected]>2018-06-29 00:29:24 +0300
commitb06bf44e3357e245f6d7b7fe7283dd7a1f691d83 (patch)
tree49f4d9f22562f83dd13bf8a6d6ab2e701e0f128b /kvmd/setup.py
parent9237bb020d098f62877622f4926aef9f5f72153b (diff)
build
Diffstat (limited to 'kvmd/setup.py')
-rwxr-xr-xkvmd/setup.py51
1 files changed, 51 insertions, 0 deletions
diff --git a/kvmd/setup.py b/kvmd/setup.py
new file mode 100755
index 00000000..30316b37
--- /dev/null
+++ b/kvmd/setup.py
@@ -0,0 +1,51 @@
+#!/usr/bin/env python3
+
+
+from setuptools import setup
+
+
+# =====
+def main() -> None:
+ with open("requirements.txt") as requirements_file:
+ install_requires = list(filter(None, requirements_file.read().splitlines()))
+
+ setup(
+ name="kvmd",
+ version="0.1",
+ url="https://github.com/mdevaev/pi-kvm",
+ license="GPLv3",
+ author="Maxim Devaev",
+ author_email="[email protected]",
+ description="The main Pi-KVM daemon",
+ platforms="any",
+
+ packages=[
+ "kvmd",
+ "kvmd.extras",
+ ],
+
+ entry_points={
+ "console_scripts": [
+ "kvmd = kvmd:main",
+ "kvmd-cleanup = kvmd.extras.cleanup:main",
+ "kvmd-wscli = kvmd.extras.wscli:main",
+ ],
+ },
+
+ install_requires=install_requires,
+
+ classifiers=[
+ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
+ "Development Status :: 3 - Alpha",
+ "Programming Language :: Python :: 3.6",
+ "Topic :: System :: Systems Administration",
+ "Operating System :: POSIX :: Linux",
+ "Intended Audience :: System Administrators",
+ "Intended Audience :: End Users/Desktop",
+ "Intended Audience :: Telecommunications Industry",
+ ],
+ )
+
+
+if __name__ == "__main__":
+ main()