summaryrefslogtreecommitdiff
path: root/kvmd/PKGBUILD
diff options
context:
space:
mode:
authorDevaev Maxim <[email protected]>2018-06-29 00:29:24 +0300
committerDevaev Maxim <[email protected]>2018-06-29 00:29:24 +0300
commitb06bf44e3357e245f6d7b7fe7283dd7a1f691d83 (patch)
tree49f4d9f22562f83dd13bf8a6d6ab2e701e0f128b /kvmd/PKGBUILD
parent9237bb020d098f62877622f4926aef9f5f72153b (diff)
build
Diffstat (limited to 'kvmd/PKGBUILD')
-rw-r--r--kvmd/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/kvmd/PKGBUILD b/kvmd/PKGBUILD
new file mode 100644
index 00000000..c603814a
--- /dev/null
+++ b/kvmd/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Maxim Devaev <[email protected]>
+# Author: Maxim Devaev <[email protected]>
+
+
+pkgname="kvmd"
+pkgver="0.1"
+pkgrel="1"
+pkgdesc="The main Pi-KVM daemon"
+arch=("any")
+url="https://github.com/mdevaev/pi-kvm"
+license=("GPL")
+depends=(
+ "python"
+ "python-yaml"
+ "python-aiohttp"
+ "python-raspberry-gpio"
+)
+backup=("etc/kvmd.yaml")
+makedepends=("python-setuptools" "wget")
+
+
+build() {
+ cd $startdir/src
+ if [ ! -d $pkgname-$pkgver ]; then
+ msg "Downloading tag v$pkgver..."
+ wget $url/archive/v$pkgver.tar.gz
+ tar -xzf v$pkgver.tar.gz
+ fi
+
+ rm -rf $pkgname-build
+ cp -r $pkgname-$pkgver $pkgname-build
+ cd $pkgname-build/kvmd
+
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$pkgname-build/kvmd
+ python setup.py install --root=$pkgdir
+
+ install -Dm644 kvmd.yaml $pkgdir/etc/kvmd.yaml
+ install -Dm644 kvmd.service "$pkgdir"/usr/lib/systemd/system/nginx.service
+}