summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevaev Maxim <[email protected]>2019-02-17 06:08:52 +0300
committerDevaev Maxim <[email protected]>2019-02-17 06:08:52 +0300
commitc42dc07f0be9ecd062518a17e6492957b2ccee47 (patch)
tree422fa50bc813393d4a3bc766cb1fce6cd1cc2990 /PKGBUILD
parentfccfd111507bb25ecc9be53d48e6b32397bd7889 (diff)
optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77004d39..c0fc79de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,10 @@ depends=(
nginx-mainline
openssl
)
+optdepends=(
+ dkms
+ tc358743-dkms
+)
makedepends=(python-setuptools)
source=("$url/archive/v$pkgver.tar.gz")
md5sums=(SKIP)
@@ -100,10 +104,7 @@ for _platform in $_PLATFORMS; do
ln -sf \"$_cfgdir/os/modules-load/$_platform.conf\" \"$pkgdir/etc/modules-load.d/pikvm.conf\"
ln -sf \"$_cfgdir/kvmd/main/$_platform.yaml\" \"$pkgdir/etc/kvmd/main.yaml\"
- if [ $_platform == v1-hdmi ]; then
- depends+=(dkms tc358743-dkms)
- ln -sf \"$_cfgdir/kvmd/tc358743-edid.hex\" \"$pkgdir/etc/kvmd/tc358743-edid.hex\"
- fi
+ [ $_platform == v1-hdmi ] && ln -sf \"$_cfgdir/kvmd/tc358743-edid.hex\" \"$pkgdir/etc/kvmd/tc358743-edid.hex\"
}"
done
done