summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Devaev <[email protected]>2023-10-21 06:25:27 +0300
committerMaxim Devaev <[email protected]>2023-10-21 06:25:27 +0300
commit51bad1dc98100a6d591dca766fc3fd8c00438a33 (patch)
tree3e2f6ac85f2b9195fd1e7c3ae274a6ec25855e37 /PKGBUILD
parent13d8dcac599040ec89cb55f013101cf93c7fe74f (diff)
install platformio and other things only on v0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 503ba455..8439db07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -81,10 +81,6 @@ depends=(
"v4l-utils>=1.22.1-1"
"nginx-mainline>=1.25.1"
openssl
- platformio
- avrdude-pikvm
- make
- patch
sudo
iptables
iproute2
@@ -215,6 +211,10 @@ for _variant in "${_variants[@]}"; do
etc/kvmd/main.yaml
)
+ if [[ $_base == v0 ]]; then
+ depends=(\"\${depends[@]}\" platformio avrdude-pikvm make patch)
+ fi
+
if [[ $_platform =~ ^.*-hdmiusb$ ]]; then
install -Dm755 -t \"\$pkgdir/usr/bin\" scripts/kvmd-udev-hdmiusb-check
fi